fd_template_creator 0.1.3 copy "fd_template_creator: ^0.1.3" to clipboard
fd_template_creator: ^0.1.3 copied to clipboard

A Dart script to generate a template for a Flutter project from a boilerplate code repository.

2
likes
130/ 140
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 4 API elements (25.0 %) have documentation comments.

Some symbols that are missing documentation: fd_template_creator, fd_template_creator.CommandRunner, fd_template_creator.CommandRunner.CommandRunner.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:fd_template_creator/fd_template_creator.dart that imports:
  • package:fd_template_creator/src/command_runner.dart that imports:
  • package:fd_template_creator/src/extensions.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

2
likes
130
pub points
0%
popularity

Publisher

verified publisherfloating-dartists.dev

A Dart script to generate a template for a Flutter project from a boilerplate code repository.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

yaml

More

Packages that depend on fd_template_creator