fcnui 1.0.6 copy "fcnui: ^1.0.6" to clipboard
fcnui: ^1.0.6 copied to clipboard

The fcnui CLI (Command-Line Interface) tool. It is used to generate component code for the fcnui package.

5
likes
160/ 160
pub points
42%
popularity

We analyzed this package 5 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.4.0 5.5.0+1 5.5.0+1
fpdart ^1.1.0 1.1.0 1.1.0
yaml_edit ^2.1.1 2.2.1 2.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
dio_web_adapter - 1.0.1 1.0.1
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

5
likes
160
pub points
42%
popularity

Publisher

verified publishershoh.dev

The fcnui CLI (Command-Line Interface) tool. It is used to generate component code for the fcnui package.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (license)

Dependencies

dio, fpdart, yaml_edit

More

Packages that depend on fcnui