fast_immutable_collections 10.2.4 copy "fast_immutable_collections: ^10.2.4" to clipboard
fast_immutable_collections: ^10.2.4 copied to clipboard

Immutable lists, sets, maps, and multimaps, which are as fast as their native mutable counterparts. Extension methods and comparators for native Dart collections.

331
likes
150/ 160
pub points
97%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

896 out of 1159 API elements (77.3 %) have documentation comments.

Some symbols that are missing documentation: fast_immutable_collections.CanBeEmpty.isEmpty, fast_immutable_collections.CanBeEmpty.isNotEmpty, fast_immutable_collections.ConfigList.copyWith, fast_immutable_collections.ConfigMap.copyWith, fast_immutable_collections.ConfigMapOfSets.asConfigMap.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 139 issues. Showing the first 2:

INFO: Statements in an if should be enclosed in a block.

lib/src/base/immutable_collection.dart:43:7

   ╷
43 │       throw StateError("Can't change the configuration of immutable collections.");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/base/immutable_collection.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/base/immutable_collection.dart:57:7

   ╷
57 │       throw StateError("Can't change the configuration of immutable collections.");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/base/immutable_collection.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.0 1.19.0 1.19.0
meta ^1.8.0 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

331
likes
150
pub points
97%
popularity

Publisher

verified publisherglasberg.dev

Immutable lists, sets, maps, and multimaps, which are as fast as their native mutable counterparts. Extension methods and comparators for native Dart collections.

Repository (GitHub)
View/report issues

Topics

#collections #immutable #data-structures #functional

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

collection, meta

More

Packages that depend on fast_immutable_collections