fast_app 0.0.2

  • Readme
  • Changelog
  • Installing
  • new41

fast_app #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1,设置终端代理 2,flutter packages pub publish --server=https://pub.dartlang.org

0.0.1

Initial version, created by bineanzhou

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fast_app: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fast_app/fast_app.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform ios

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform linux

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform macos

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform web

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_web.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because of import path [package:fast_app/fast_app.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

because of import path [fast_app] that is in a package requiring null.

Health suggestions

Fix lib/net/http/fast_api_request.dart. (-1.99 points)

Analysis of lib/net/http/fast_api_request.dart reported 4 hints:

line 3 col 35: The name Platform is shown, but isn’t used.

line 33 col 12: The value of the local variable 'cacheKey' isn't used.

line 49 col 13: The value of the local variable 'timestamp' isn't used.

line 133 col 17: The value of the local variable 'cacheIt' isn't used.

Fix lib/net/fast_respone_model.dart. (-0.50 points)

Analysis of lib/net/fast_respone_model.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:convert'.

Fix lib/net/http/fast_app_http.dart. (-0.50 points)

Analysis of lib/net/http/fast_app_http.dart reported 1 hint:

line 225 col 19: The value of the local variable 'response' isn't used.

Fix additional 34 files with analysis or formatting issues. (-2 points)

Additional issues in the following files:

  • lib/ui/select/fast_select_image_view.dart (1 hint)
  • lib/ui/state/fast_state.dart (1 hint)
  • lib/ui/textfield/fast_text_field.dart (1 hint)
  • lib/util/fast_theme.dart (1 hint)
  • lib/cache/app_cache.dart (Run flutter format to format lib/cache/app_cache.dart.)
  • lib/cache/fast_cache.dart (Run flutter format to format lib/cache/fast_cache.dart.)
  • lib/cache/web_cache.dart (Run flutter format to format lib/cache/web_cache.dart.)
  • lib/data/fast_data.dart (Run flutter format to format lib/data/fast_data.dart.)
  • lib/fast_app.dart (Run flutter format to format lib/fast_app.dart.)
  • lib/fast_app_config.dart (Run flutter format to format lib/fast_app_config.dart.)
  • lib/generated/i18n.dart (Run flutter format to format lib/generated/i18n.dart.)
  • lib/net/fast_config.dart (Run flutter format to format lib/net/fast_config.dart.)
  • lib/net/fast_net.dart (Run flutter format to format lib/net/fast_net.dart.)
  • lib/net/fast_view_model.dart (Run flutter format to format lib/net/fast_view_model.dart.)
  • lib/net/grpc/fast_app_grpc.dart (Run flutter format to format lib/net/grpc/fast_app_grpc.dart.)
  • lib/theme/fast_theme.dart (Run flutter format to format lib/theme/fast_theme.dart.)
  • lib/ui/alert/fast_alert.dart (Run flutter format to format lib/ui/alert/fast_alert.dart.)
  • lib/ui/appbar/fast_appbar.dart (Run flutter format to format lib/ui/appbar/fast_appbar.dart.)
  • lib/ui/banner/banner_view.dart (Run flutter format to format lib/ui/banner/banner_view.dart.)
  • lib/ui/button/fast_button.dart (Run flutter format to format lib/ui/button/fast_button.dart.)
  • lib/ui/button/fast_mini_button.dart (Run flutter format to format lib/ui/button/fast_mini_button.dart.)
  • lib/ui/dialog/fast_confirm_dialog.dart (Run flutter format to format lib/ui/dialog/fast_confirm_dialog.dart.)
  • lib/ui/fast_app_ui.dart (Run flutter format to format lib/ui/fast_app_ui.dart.)
  • lib/ui/group/fast_group_row.dart (Run flutter format to format lib/ui/group/fast_group_row.dart.)
  • lib/ui/list_view/fast_list_view.dart (Run flutter format to format lib/ui/list_view/fast_list_view.dart.)
  • lib/ui/separator/fast_separator.dart (Run flutter format to format lib/ui/separator/fast_separator.dart.)
  • lib/ui/tabbar/fast_root_tabbar.dart (Run flutter format to format lib/ui/tabbar/fast_root_tabbar.dart.)
  • lib/ui/textfield/fast_row_view.dart (Run flutter format to format lib/ui/textfield/fast_row_view.dart.)
  • lib/ui/textfield/fast_search_view.dart (Run flutter format to format lib/ui/textfield/fast_search_view.dart.)
  • lib/util/fast_platform.dart (Run flutter format to format lib/util/fast_platform.dart.)
  • lib/util/fast_util.dart (Run flutter format to format lib/util/fast_util.dart.)
  • lib/util/param_util.dart (Run flutter format to format lib/util/param_util.dart.)
  • lib/util/vm_plaform.dart (Run flutter format to format lib/util/vm_plaform.dart.)
  • lib/util/web_platform.dart (Run flutter format to format lib/util/web_platform.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and fast_app.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cached_network_image 2.2.0+1 2.2.0+1 2.3.0-rc
cupertino_icons ^0.1.2 0.1.3
dio ^3.0.7 3.0.9
dio_http2_adapter ^1.0.0 1.0.0
flutter 0.0.0
flutter_swiper ^1.1.6 1.1.6
grpc ^2.1.2 2.2.0
html ^0.14.0+3 0.14.0+3
intl ^0.16.0 0.16.1
json_annotation ^3.0.1 3.0.1
protobuf ^1.0.0 1.0.1
scoped_model ^1.0.1 1.0.1
shared_preferences ^0.5.4+8 0.5.7+3
toast ^0.1.5 0.1.5
url_launcher ^5.4.2 5.4.11
Transitive dependencies
async 2.4.1
charcode 1.1.3
clock 1.0.1
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
file 5.2.1
fixnum 0.10.11
flutter_cache_manager 1.4.1
flutter_page_indicator 0.0.3
flutter_web_plugins 0.0.0
googleapis_auth 0.2.12
http 0.12.1
http2 1.0.0
http_parser 3.1.4
meta 1.1.8
path 1.7.0
path_provider 1.6.11
path_provider_linux 0.0.1+2
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
pedantic 1.9.0 1.9.1
platform 2.2.1
platform_detect 1.4.0
plugin_platform_interface 1.0.2
process 3.0.13
pub_semver 1.4.4
rxdart 0.24.1
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
sqflite 1.3.1
sqflite_common 1.0.2+1
string_scanner 1.0.5
synchronized 2.2.0+1
term_glyph 1.1.0
transformer_page_view 0.1.6
typed_data 1.1.6 1.2.0
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
uuid 2.2.0
vector_math 2.0.8
xdg_directories 0.1.0
Dev dependencies
flutter_test