ezanimation 0.6.0 copy "ezanimation: ^0.6.0" to clipboard
ezanimation: ^0.6.0 copied to clipboard

Easy Animations - No Controllers, No Tickers, Only the necessary parts.

119
likes
130/ 140
pub points
83%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 32 API elements (78.1 %) have documentation comments.

Some symbols that are missing documentation: ezanimation, ezanimation.EzAnimation.vsync, ezanimation.SequenceItem, ezanimation.SequenceItem.SequenceItem, ezanimation.SequenceItem.begin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: An uninitialized field should have an explicit type annotation.

lib/ezanimation.dart:13:12

   ╷
13 │   late var begin;
   │            ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ezanimation.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/ezanimation.dart:16:12

   ╷
16 │   late var end;
   │            ^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ezanimation.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

119
likes
130
pub points
83%
popularity

Publisher

verified publisherjoshi.dev

Easy Animations - No Controllers, No Tickers, Only the necessary parts.

Repository

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on ezanimation