ez 0.0.3
ez: ^0.0.3 copied to clipboard

A wrapper class around flutter_driver API. Allows you to replace verbose calls like driver.tap(find.byValueKey("my-key")) with ez.tap("my-key")

0
likes
80 / 130
pub points
2 %
popularity

We analyzed this package on May 8, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 13 API elements (7.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:ez/ez.dart that imports:
  • package:flutter_driver/flutter_driver.dart that imports:
  • package:flutter_driver/src/driver/timeline_summary.dart that imports:
  • package:flutter_driver/src/driver/common.dart that imports:
  • package:file/memory.dart that imports:
  • package:file/src/backends/memory.dart that imports:
  • package:file/src/backends/memory/style.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_driverflutter0.0.00.0.0
test^1.0.01.16.51.17.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
archive-2.0.133.1.2
args-1.6.02.1.0
async-2.5.02.6.1
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
coverage-0.15.21.0.2
crypto-2.1.53.0.1
fake_async-1.2.01.2.0
file-6.0.06.1.0
fuchsia_remote_debug_protocol-0.0.00.0.0
glob-2.0.12.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-1.4.132.0.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
pool-1.5.01.5.0
process-4.0.04.2.1
pub_semver-2.0.02.0.0
shelf-1.1.21.1.2
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.1
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.01.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
sync_http-0.2.00.3.0
term_glyph-1.2.01.2.0
test_api-0.2.190.4.0
test_core-0.3.150.3.23
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
vm_service-5.5.06.2.0
watcher-1.0.01.0.0
web_socket_channel-1.2.02.1.0
webdriver-2.1.23.0.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

0
likes
80
pub points
2%
popularity

A wrapper class around flutter_driver API. Allows you to replace verbose calls like driver.tap(find.byValueKey("my-key")) with ez.tap("my-key")

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

luke.cherrish@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_driver, test

More

Packages that depend on ez