expressions 0.2.4 icon indicating copy to clipboard operation
expressions: ^0.2.4 copied to clipboard

A library to parse and evaluate simple dart and javascript like expressions.

52
likes
115/ 130
pub points
92%
popularity

We analyzed this package 5 days ago, and awarded it 115 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:7:29

  ╷
7 │ <p>It is partly inspired by <a href="http://jsep.from.so/">jsep</a>.</p>
  │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 82 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
fake_async^1.2.01.3.11.3.1
meta^1.3.01.8.01.8.0
petitparser^5.0.05.0.05.0.0
quiver^3.0.03.1.03.1.0
rxdart^0.27.00.27.50.27.5
Transitive dependencies
PackageConstraintCompatibleLatest
clock-1.1.11.1.1
collection-1.16.01.16.0
matcher-0.12.120.12.12
path-1.8.21.8.2
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Dart 2.17.6.

52
likes
115
pub points
92%
popularity

Publisher

verified publisher iconappsup.be

A library to parse and evaluate simple dart and javascript like expressions.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

fake_async, meta, petitparser, quiver, rxdart

More

Packages that depend on expressions