express_dt 1.0.5 copy "express_dt: ^1.0.5" to clipboard
express_dt: ^1.0.5 copied to clipboard

A Dart library to easily create http servers and perform requests.

7
likes
100/ 140
pub points
30%
popularity

We analyzed this package 6 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

123 out of 269 API elements (45.7 %) have documentation comments.

Some symbols that are missing documentation: express_dt, express_dt.Cors, express_dt.Cors.Cors, express_dt.Cors.allowed_origins, express_dt.Express.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:express_dt/express_dt.dart that imports:
  • package:express_dt/src/session/verifysession.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 135 issues. Showing the first 2:

WARNING: The value of the local variable 'data' isn't used.

lib/src/foundation.dart:530:26

    ╷
530 │           await for (var data in fileC.streamController!.stream) {
    │                          ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/foundation.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/src/http_server/src/http_multipart_form_data_impl.dart:34:33

   ╷
34 │     if (contentTransferEncoding != null) {
   │                                 ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/http_server/src/http_multipart_form_data_impl.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
crypto ^3.0.1 3.0.3 3.0.3
dotenv ^3.0.0 3.0.0 4.2.0
flutter flutter 0.0.0 0.0.0
path ^1.8.0 1.9.0 1.9.0
pedantic ^1.11.0 1.11.1 1.11.1
stack_trace ^1.10.0 1.11.1 1.11.1
universal_io ^2.0.4 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on dotenv does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dotenv to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

7
likes
100
pub points
30%
popularity

Publisher

unverified uploader

A Dart library to easily create http servers and perform requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

collection, crypto, dotenv, flutter, path, pedantic, stack_trace, universal_io

More

Packages that depend on express_dt