explo_capture 0.1.0+2 copy "explo_capture: ^0.1.0+2" to clipboard
explo_capture: ^0.1.0+2 copied to clipboard

Capture render tree data of a Flutter app, for visualization with Explo.

6
likes
120/ 140
pub points
49%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 22 API elements (86.4 %) have documentation comments.

Some symbols that are missing documentation: explo_capture, internal.renderTreeFromJson, internal.renderTreeToJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/capture_service_extensions.dart:96:28

   ╷
96 │   SchedulerBinding.instance!.addPersistentFrameCallback((_) {
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/capture_service_extensions.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/capture_service_extensions.dart:98:32

   ╷
98 │       SchedulerBinding.instance!.addPostFrameCallback((_) {
   │                                ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/capture_service_extensions.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

6
likes
120
pub points
49%
popularity

Publisher

verified publishergabriel.terwesten.net

Capture render tree data of a Flutter app, for visualization with Explo.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on explo_capture