esc_pos_bluetooth 0.4.1 copy "esc_pos_bluetooth: ^0.4.1" to clipboard
esc_pos_bluetooth: ^0.4.1 copied to clipboard

The library allows to print receipts using an ESC/POS thermal Bluetooth printer.

137
likes
80/ 140
pub points
93%
popularity

We analyzed this package 17 hours ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 22 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: esc_pos_bluetooth, esc_pos_bluetooth.PosPrintResult, esc_pos_bluetooth.PosPrintResult.msg, esc_pos_bluetooth.PosPrintResult.printInProgress, esc_pos_bluetooth.PosPrintResult.printerNotSelected.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:esc_pos_bluetooth/esc_pos_bluetooth.dart that imports:
  • package:esc_pos_bluetooth/src/printer_bluetooth_manager.dart that imports:
  • package:flutter_bluetooth_basic/flutter_bluetooth_basic.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:esc_pos_bluetooth/esc_pos_bluetooth.dart that imports:
  • package:esc_pos_bluetooth/src/printer_bluetooth_manager.dart that imports:
  • package:flutter_bluetooth_basic/flutter_bluetooth_basic.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:esc_pos_bluetooth/esc_pos_bluetooth.dart that imports:
  • package:esc_pos_bluetooth/src/printer_bluetooth_manager.dart that imports:
  • package:flutter_bluetooth_basic/flutter_bluetooth_basic.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:esc_pos_bluetooth/esc_pos_bluetooth.dart that imports:
  • package:esc_pos_bluetooth/src/printer_bluetooth_manager.dart that imports:
  • package:flutter_bluetooth_basic/flutter_bluetooth_basic.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Unused import: 'package:esc_pos_utils/esc_pos_utils.dart'.

lib/src/printer_bluetooth_manager.dart:11:8

   ╷
11 │ import 'package:esc_pos_utils/esc_pos_utils.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/printer_bluetooth_manager.dart

failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
esc_pos_utils ^1.1.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
flutter_bluetooth_basic ^0.1.7 0.1.7 0.1.7
rxdart ^0.26.0 0.26.0 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
gbk_codec - 0.4.0 0.4.0
hex - 0.2.0 0.2.0
html - 0.15.4 0.15.4
image - 3.3.0 4.1.7
js - 0.7.1 0.7.1
json_annotation - 4.8.1 4.8.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.7.4 3.7.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

137
likes
80
pub points
93%
popularity

Publisher

verified publishertablemi.com

The library allows to print receipts using an ESC/POS thermal Bluetooth printer.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

esc_pos_utils, flutter, flutter_bluetooth_basic, rxdart

More

Packages that depend on esc_pos_bluetooth