epub_viewer_new 0.0.6 copy "epub_viewer_new: ^0.0.6" to clipboard
epub_viewer_new: ^0.0.6 copied to clipboard

epub_viewer is an epub ebook reader that encapsulates the folioreader framework.

0
likes
140/ 160
pub points
11%
popularity

We analyzed this package 13 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 26 API elements (42.3 %) have documentation comments.

Some symbols that are missing documentation: epub_viewer_new, epub_viewer_new.EpubLocator.bookId, epub_viewer_new.EpubLocator.created, epub_viewer_new.EpubLocator.EpubLocator.fromJson, epub_viewer_new.EpubLocator.href.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:epub_viewer_new/epub_viewer_new.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:epub_viewer_new/epub_viewer_new.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:epub_viewer_new/epub_viewer_new.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:epub_viewer_new/epub_viewer_new.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/epub_viewer_new.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/model/epub_locator.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
path ^1.8.2 1.9.0 1.9.0
path_provider ^2.0.13 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
140
pub points
11%
popularity

Publisher

unverified uploader

epub_viewer is an epub ebook reader that encapsulates the folioreader framework.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, path, path_provider

More

Packages that depend on epub_viewer_new