epub 2.1.0

Dart native js
Flutter Android iOS web

Epub Parser for Dart. Suitable for use on the Server, the Web, or in Flutter

24
likes
85 / 110
pub points
82 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:27

  ╷
3 │ <p>The format is based on <a href="http://keepachangelog.com/en/1.0.0/">Keep a Changelog</a>
  │                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 156 API elements (9.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.02.0.132.0.13
async>=1.8.0 <3.0.02.4.22.4.2
dart2_constant^1.0.11.0.2+dart21.0.2+dart2
image>=1.1.33 <3.0.02.1.132.1.18
quiver>=2.0.0 <3.0.02.1.32.1.3
xml>=2.6.0 <4.0.03.7.04.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
matcher-0.12.90.12.9
meta-1.2.31.2.3
petitparser-3.1.03.1.0
stack_trace-1.9.51.9.5
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.6.0 <4.0.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:12:8

   ╷
12 │   xml: ">=2.6.0 <4.0.0"
   │        ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

24
likes
85
pub points
82%
popularity

Epub Parser for Dart. Suitable for use on the Server, the Web, or in Flutter

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

colinnlsn@gmail.com

License

MIT (LICENSE)

Dependencies

archive, async, dart2_constant, image, quiver, xml

More

Packages that depend on epub