entity 3.0.2 copy "entity: ^3.0.2" to clipboard
entity: ^3.0.2 copied to clipboard

A simple ORM for Relational and NoSQL database, such as Couchbase and PostgreSQL.

10
likes
130/ 160
pub points
73%
popularity

We analyzed this package 26 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

110 out of 119 API elements (92.4 %) have documentation comments.

Some symbols that are missing documentation: entity, entity.CachedAccessReader.cache, entity.EntityException.message, entity.EntityNotFoundException.oid, entity.map_storage.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 48 issues. Showing the first 2:

WARNING: This function has a nullable return type of 'Future

lib/map_storage.dart:94:11

   ╷
94 │   Future? update(Entity entity, Map data, Iterable<String>? fields) {
   │           ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/map_storage.dart

WARNING: This function has a nullable return type of 'Future

lib/map_storage.dart:109:11

    ╷
109 │   Future? create(Entity entity, Map data) {
    │           ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/map_storage.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
charcode >=1.0.0 <2.0.0 1.3.1 1.3.1
postgresql2 >=1.0.0 1.6.2 1.6.2
rikulo_commons >=3.0.0 6.1.0 6.1.0
Transitive dependencies
Package Constraint Compatible Latest
buffer - 1.2.3 1.2.3
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
logging - 1.2.0 1.2.0
mime - 1.0.5 1.0.5
sasl_scram - 0.1.1 0.1.1
saslprep - 1.0.3 1.0.3
typed_data - 1.3.2 1.3.2
unorm_dart - 0.3.0 0.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

10
likes
130
pub points
73%
popularity

Publisher

verified publisherquire.io

A simple ORM for Relational and NoSQL database, such as Couchbase and PostgreSQL.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Apache-2.0 (license)

Dependencies

charcode, postgresql2, rikulo_commons

More

Packages that depend on entity