entity 1.9.0+1

Dart native js
Flutter Android iOS web

A simple ORM for Relational and NoSQL database, such as Couchbase and PostgreSQL.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  entity: ^1.9.0+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:entity/entity.dart';
1
likes
85
pub points
60%
popularity

A simple ORM for Relational and NoSQL database, such as Couchbase and PostgreSQL.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

tomyeh@rikulo.org

License

Apache 2.0 (LICENSE)

Dependencies

charcode, postgresql2, rikulo_commons

More

Packages that depend on entity