endorse_builder 0.0.28
endorse_builder: ^0.0.28 copied to clipboard

Library for validating random objects like API responses. This is the code generator.

0
likes
60 / 110
pub points
2 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:endorse_builder/endorse_builder.dart that imports:
  • package:endorse_builder/src/endorse_builder.dart that imports:
  • package:endorse_builder/src/endorse_entity_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/src/endorse_class_helper.dart:283:31

    ╷
283 │         const fromStringRules = const [
    │ ┌───────────────────────────────^
284 │ │         'IntFromString',
285 │ │         'DoubleFromString',
286 │ │         'NumFromString',
287 │ │         'BoolFromString'
288 │ │       ];
    │ └───────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/endorse_class_helper.dart

INFO: Avoid const keyword.

lib/src/endorse_class_helper.dart:318:33

    ╷
318 │           const fromStringRules = const [
    │ ┌─────────────────────────────────^
319 │ │           'IntFromString',
320 │ │           'DoubleFromString',
321 │ │           'NumFromString',
322 │ │           'BoolFromString'
323 │ │         ];
    │ └─────────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/endorse_class_helper.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.40.40.61.4.0
build^1.5.11.6.22.0.0
endorse^0.0.20.0.280.0.28
recase^3.0.03.0.13.0.1
source_gen^0.9.80.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.020.0.0
args-1.6.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart_style-1.3.102.0.0
file-5.2.16.1.0
glob-1.2.02.0.1
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.11.0.1
meta-1.3.01.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.40.4` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.5.1` on build does not support the stable version `2.0.0`, that was published 26 days ago.

When build is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
60
pub points
2%
popularity

Library for validating random objects like API responses. This is the code generator.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kirklinkletter@gmail.com

License

BSD (LICENSE)

Dependencies

analyzer, build, endorse, recase, source_gen

More

Packages that depend on endorse_builder