endorse 0.0.1

endorse #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  endorse: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:endorse/endorse.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
68
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Nov 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:endorse/endorse.dart.

Health issues and suggestions

Fix lib/src/endorse.dart. (-27.95 points)

Analysis of lib/src/endorse.dart failed with 1 error, 8 hints, including:

line 187 col 15: The function 'JsonTool' isn't defined.

line 7 col 50: Use lowercase_with_underscores when specifying a library prefix.

line 64 col 7: DO use curly braces for all flow control structures.

line 99 col 7: DO use curly braces for all flow control structures.

line 116 col 13: Use isNotEmpty instead of length

Document public APIs. (-1 points)

56 out of 56 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/validation.dart. (-2.48 points)

Analysis of lib/src/validation.dart reported 5 hints:

line 32 col 65: Use = to separate a named parameter from its default value.

line 56 col 13: Use isNotEmpty instead of length

line 79 col 43: Use = to separate a named parameter from its default value.

line 131 col 16: Use isEmpty instead of length

line 134 col 30: Use = to separate a named parameter from its default value.

Fix lib/src/rule_set.dart. (-1.99 points)

Analysis of lib/src/rule_set.dart reported 4 hints:

line 5 col 8: Unused import: 'package:bottom_line/bottom_line.dart'.

line 5 col 50: Use lowercase_with_underscores when specifying a library prefix.

line 464 col 12: The value of the local variable 'isValid' isn't used.

line 476 col 11: Use isEmpty instead of length

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and endorse.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
bottom_line ^0.0.3 0.0.4
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.3
typed_data 1.1.6
uuid 2.0.2
Dev dependencies
mockito ^3.0.0
test ^1.3.3