elixir 2.0.1 icon indicating copy to clipboard operation
elixir: ^2.0.1 copied to clipboard

Tool for commenting `dart analyze` results to GitHub PullRequest.

1
likes
130/ 140
pub points
0%
popularity

We analyzed this package 37 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

64 out of 237 API elements (27.0 %) have documentation comments.

Some symbols that are missing documentation: analyze_result, AnalyzeResult, AnalyzeResult, column, errorCode.

10/10 points: Package has an example

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:elixir/elixir.dart that imports:
  • package:elixir/cli/runner.dart that imports:
  • package:elixir/cli/command/run.dart that imports:
  • package:elixir/usecase/get_indicates.dart that imports:
  • package:elixir/data/repository/git.dart that imports:
  • package:elixir/data/source/process.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
50 / 50icon to trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.1 2.4.2 2.4.2
http ^0.13.5 0.13.6 1.1.2
meta ^1.8.0 1.11.0 1.11.0
path ^1.8.2 1.8.3 1.8.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.21.43, Dart 3.2.1.

Check the analysis log for details.

1
likes
130
pub points
0%
popularity

Publisher

verified publisher iconblendthink.dev

Tool for commenting `dart analyze` results to GitHub PullRequest.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

args, http, meta, path

More

Packages that depend on elixir