elevated_ticket_widget 0.0.4 copy "elevated_ticket_widget: ^0.0.4" to clipboard
elevated_ticket_widget: ^0.0.4 copied to clipboard

A Flutter package which will help you to generate ticket shaped widget with elevation, highly customizable and flexible.

9
likes
160/ 160
pub points
74%
popularity

We analyzed this package 2 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 17 API elements (76.5 %) have documentation comments.

Some symbols that are missing documentation: elevated_ticket_widget, elevated_ticket_widget.ElevatedTicketWidget, ticket_painter, ticket_painter.TicketPainter.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:elevated_ticket_widget/elevated_ticket_widget.dart that imports:
  • package:elevated_ticket_widget/ticket_painter.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

9
likes
160
pub points
74%
popularity
screenshot

Publisher

verified publishercooltechie.info

A Flutter package which will help you to generate ticket shaped widget with elevation, highly customizable and flexible.

Repository (GitHub)
View/report issues

Topics

#ticket-shape #ticket-ui #ticket-widget #ticket-elevation #flutter-ticket

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on elevated_ticket_widget