elastic_widgets 0.0.3
elastic_widgets: ^0.0.3 copied to clipboard

Set of Flutter widgets built using physics based animations.

10
likes
40 / 110
pub points
19 %
popularity

We analyzed this package on Jan 23, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 383 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:elastic_widgets/src/range_picker/range_picker_painter.dart'.

lib/src/range_picker/elastic_range_picker.dart:1:8

  ╷
1 │ import 'package:elastic_widgets/src/range_picker/range_picker_painter.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/range_picker/elastic_range_picker.dart

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/src/range_picker/elastic_range_picker.dart:2:8

  ╷
2 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/range_picker/elastic_range_picker.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because every version of flutter_test from sdk depends on collection 1.15.0-nullsafety.5 and dartx >=0.2.0 <0.5.0 depends on collection >=1.14.11 <1.15.0, flutter_test from sdk is incompatible with dartx >=0.2.0 <0.5.0.
So, because elastic_widgets depends on both dartx ^0.4.2 and flutter_test any from sdk, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

10
likes
40
pub points
19%
popularity

Set of Flutter widgets built using physics based animations.

Repository (GitHub)
View/report issues

Uploader

abiriali78@gmail.com

License

BSD (LICENSE)

Dependencies

dartx, flutter

More

Packages that depend on elastic_widgets