elastic_widgets 0.0.3

Flutter Android iOS web

Set of Flutter widgets built using physics based animations.

Elastic Widgets #

Set of Flutter widgets built using physics based animations.

Widgets #

Seek BarRange Picker
seekbar gifenter image description here

Installation #

Add this to your package's pubspec.yaml file
dependencies:
 elastic_widgets: 0.0.1

Usage #

Seek bar: #

 ElasticSeekBar(
	 valueListener: (value) {
	   print("slider value: $value");
	 },
	 size: Size(300, 100),
	 stretchRange: 50.0,
	 minValue: 0,
	 maxValue: 100,
	 circleRadius: 12,
	 thinLineStrokeWidth: 3,
	 thickLineStrokeWidth: 4,
	 thickLineColor: Colors.blue,
	 thinLineColor: Colors.blueGrey,
	 bounceDuration: Duration(seconds: 1),
	 stiffness: 300,
	 dampingRatio: 5,
),

Range picker: #

 ElasticRangePicker(
	 valueListener: (firstValue, secondValue) {
	   print("range picker first value: $firstValue");
	   print("range picker second value: $secondValue");
	 },
	 size: Size(300, 100),
	 stretchRange: 50.0,
	 minValue: 0,
	 maxValue: 100,
	 circleRadius: 12,
	 thinLineStrokeWidth: 3,
	 thickLineStrokeWidth: 4,
	 thickLineColor: Colors.orange,
	 thinLineColor: Colors.blueGrey,
	 bounceDuration: Duration(seconds: 1),
	 stiffness: 300,
	 dampingRatio: 5,
),

Planned widgets #

  • [ ] Radio button
  • [ ] Checkbox
  • [ ] Dialog
  • [ ] Button

Made with ❤️ for Flutter community - Pull requests are welcome

keywords: widget, elastic, slider, seekbar, seek bar, range picker, rangepicker

6
likes
90
pub points
34%
popularity

Set of Flutter widgets built using physics based animations.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

abiriali78@gmail.com

License

BSD (LICENSE)

Dependencies

dartx, flutter

More

Packages that depend on elastic_widgets