effortless_firebase_auth 1.0.5 icon indicating copy to clipboard operation
effortless_firebase_auth: ^1.0.5 copied to clipboard

effortless_firebase_auth A new Flutter package.

0
likes
60/ 130
pub points
16%
popularity

We analyzed this package 44 hours ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 220 API elements (8.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:effortless_firebase_auth/effortless_firebase_auth.dart that imports:
  • package:effortless_firebase_auth/Methods/email.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:effortless_firebase_auth/effortless_firebase_auth.dart that imports:
  • package:effortless_firebase_auth/Methods/email.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:effortless_firebase_auth/effortless_firebase_auth.dart that imports:
  • package:effortless_firebase_auth/Methods/email.dart that imports:
  • package:effortless_firebase_auth/screens/signUp.dart that imports:
  • package:effortless_firebase_auth/screens/signin.dart that imports:
  • package:effortless_firebase_auth/infrastructure/baseui.dart that imports:
  • package:effortless_firebase_auth/home.dart that imports:
  • package:effortless_firebase_auth/Methods/google.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 49 issues. Showing the first 2:

ERROR: Undefined class 'User'.

lib/Methods/email.dart:24:3

   ╷
24 │   User uu = fa.currentUser;
   │   ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/Methods/email.dart

ERROR: The name 'UserCredential' isn't a type so it can't be used as a type argument.

lib/Methods/email.dart:28:8

   ╷
28 │ Future<UserCredential> register(String email, String password) async {
   │        ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/Methods/email.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartzany0.10.10.10.1
device_previewany0.4.71.1.0
firebase_authany0.16.13.3.20
firebase_coreany0.4.41.18.0
flutterflutter0.0.00.0.0
flutter_form_builderany7.3.17.3.1
form_field_validatorany1.1.01.1.0
global_wingsany1.0.41.0.4
google_sign_inany5.3.35.3.3
intlany0.17.00.17.0
loggerany1.1.01.1.0
metaany1.7.01.8.0
nice_buttonany0.1.70.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.11.1.1
collection-1.16.01.16.0
ffi-1.2.12.0.1
file-6.1.26.1.2
firebase-7.3.39.0.3
firebase_auth_platform_interface-1.1.86.2.8
firebase_auth_web-0.1.3+13.3.17
firebase_core_platform_interface-1.0.04.4.1
firebase_core_web-0.1.1+21.6.5
flutter_web_plugins-0.0.00.0.0
font_awesome_flutter-8.12.010.1.0
freezed_annotation-0.11.0+12.0.3
google_sign_in_android-5.2.85.2.8
google_sign_in_ios-5.3.15.3.1
google_sign_in_platform_interface-2.2.02.2.0
google_sign_in_web-0.10.1+30.10.1+3
http-0.12.20.13.4
http_parser-3.1.44.0.1
js-0.6.40.6.4
json_annotation-3.1.14.5.0
matcher-0.12.120.12.12
material_color_utilities-0.1.40.1.5
path-1.8.21.8.2
path_provider_linux-0.0.1+22.1.7
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.0
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
quiver-3.1.03.1.0
quiver_hashcode-2.0.03.0.0+1
shared_preferences-0.5.12+42.0.15
shared_preferences_linux-0.0.2+42.1.1
shared_preferences_macos-0.0.1+112.0.4
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
win32-2.6.12.7.0
xdg_directories-0.1.20.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.