This package provides the lints according to the Effective Dart guide.
This package is inspired by the pedantic package, which contains lints internally used at Google.
Using the Lints #
To use the lints add a dev dependency in your
dev_dependencies: effective_dart: ^1.0.0
Then add an include in your
You can always specify a specific version instead:
Licensed under the MIT License.
- Add linst according to current state of the Effective Dart
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: effective_dart: ^1.0.0
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
Detected platforms: Flutter, web, other
|Dart SDK||>=2.1.1-dev.0.0 <3.0.0|