effective_dart 1.1.1

  • Readme
  • Changelog
  • Installing
  • 87

effective_dart #

pub package License: MIT

This package provides links that attempt to comply with all Effective Dart guide rules.

Be consistent. Be brief.

Note: This package is inspired by the pedantic package, which contains lints internally used at Google.

Using the Lints #

To use the lints add a dev dependency in your pubspec.yaml:

  effective_dart: ^1.1.0

Then add an include in your analysis_options.yaml file:

include: package:effective_dart/analysis_options.yaml

You can always specify a specific version instead:

include: package:effective_dart/analysis_options.1.1.0.yaml

Unused Lints #

Following lints have been considered and will not be enforced by this package:

  • lines_longer_than_80_chars might be practical not to follow for many people
  • unnecessary_getters has been disabled
  • comment_references is way too restrictive and comment references are handled in different ways in tools (see this issue)

Badge #

Show the world you're following the Effective Dart guide → style: effective dart

[![style: effective dart](https://img.shields.io/badge/style-effective_dart-40c4ff.svg)](https://github.com/tenhobi/effective_dart)

License #

Licensed under the MIT License.

Changelog #

1.1.0 #

  • Disable comment_references because it is way too restrictive (see this issue)

1.0.1 #

  • Fix SDK version.
  • Enhance README.

1.0.0 #

  • Add linst according to current state of the Effective Dart analysis_options.yaml.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  effective_dart: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0