effective_dart 1.0.0

  • Readme
  • Changelog
  • Installing
  • new51

effective_dart #

This package provides the lints according to the Effective Dart guide.

This package is inspired by the pedantic package, which contains lints internally used at Google.

Using the Lints #

To use the lints add a dev dependency in your pubspec.yaml:

dev_dependencies:
  effective_dart: ^1.0.0

Then add an include in your analysis_options.yaml file:

include: package:effective_dart/analysis_options.yaml

You can always specify a specific version instead:

include: package:effective_dart/analysis_options.1.0.0.yaml

License #

Licensed under the MIT License.

Changelog #

1.0.0 #

  • Add linst according to current state of the Effective Dart analysis_options.yaml.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  effective_dart: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Oct 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.1-dev.0.0 <3.0.0