edeskyclient 1.1.0 icon indicating copy to clipboard operation
edeskyclient: ^1.1.0 copied to clipboard

Dart client for Czech service edesky.cz API. Supports dashboards and documents querying.

0
likes
130/ 140
pub points
0%
popularity

We analyzed this package 13 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 48 out of 57 API elements (84.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.17.01.17.0
http^0.13.00.13.50.13.5
xml^5.0.25.4.16.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
http_parser-4.0.24.0.2
meta-1.8.01.8.0
path-1.8.21.8.2
petitparser-5.1.05.1.0
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^5.0.2 on xml does not support the stable version 6.0.0.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
130
pub points
0%
popularity

Publisher

verified publisher iconstol.dev

Dart client for Czech service edesky.cz API. Supports dashboards and documents querying.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

collection, http, xml

More

Packages that depend on edeskyclient