ed25519_hd_key 1.0.1
ed25519_hd_key: ^1.0.1

Dart native js
Flutter Android iOS web

BIP-0032 like derivation for ed25519 curve

1
likes
70 / 110
pub points
74 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/ed25519_hd_key.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 10 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Use `lowercase_with_underscores` when specifying a library prefix.

lib/src/base.dart:3:46

  ╷
3 │ import 'package:tweetnacl/tweetnacl.dart' as ED25519;
  │                                              ^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/base.dart

INFO: DO use curly braces for all flow control structures.

lib/src/base.dart:60:7

   ╷
60 │ ┌       throw ArgumentError(
61 │ └           "Invalid derivation path. Expected BIP32 path format");
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/base.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
hex^0.1.20.1.20.1.2
pointycastle^1.0.01.0.22.0.0
tweetnacl^0.3.10.3.20.3.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
fixnum-0.10.110.10.11
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on pointycastle does not support the latest published version `2.0.0`

pubspec.yaml:13:17

   ╷
13 │   pointycastle: ^1.0.0
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
74%
popularity

Publisher

alepop.dev

BIP-0032 like derivation for ed25519 curve

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

hex, pointycastle, tweetnacl

More

Packages that depend on ed25519_hd_key