easynetflutter 0.0.63
easynetflutter: ^0.0.63 copied to clipboard

Componentes Widget EasyNet

1
likes
60 / 130
pub points
37 %
popularity

We analyzed this package on May 7, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 218 API elements (5.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 60 issues. Showing the first 2:

INFO: Avoid using braces in interpolation when not needed.

lib/easynet/log/Logger.dart:8:61

  ╷
8 │       print("INFO: ${DateTime.now().toString()}: ClassName: ${className} - $message");
  │                                                             ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/easynet/log/Logger.dart

INFO: Avoid using braces in interpolation when not needed.

lib/easynet/log/Logger.dart:11:60

   ╷
11 │     print("ERROR: ${DateTime.now().toString()}: ClassName: ${className}) - $message");
   │                                                            ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/easynet/log/Logger.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.5.32.7.13.0.2
firebase_messaging^6.0.136.0.169.1.3
flutterflutter0.0.00.0.0
http^0.12.10.12.20.13.3
intl^0.16.10.16.10.17.0
package_info^0.4.10.4.3+42.0.0
shared_preferences^0.5.6+30.5.12+42.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
ffi-1.0.01.0.0
file-5.2.16.1.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
logging-0.11.41.0.1
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.01.11.0
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
pointycastle-2.0.13.0.1
process-3.0.134.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^2.5.3` on basic_utils does not support the stable version `3.0.0`, that was published 29 days ago.

When basic_utils is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions basic_utils to update the constraint.

The constraint `^6.0.13` on firebase_messaging does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.