easy_google_maps 1.0.0+2

easy_google_maps #

Easy Google Maps for Flutter on Web and Mobile

Getting Started #

Mobile #

Follow setup for Mobile Here

Web #

Good to go!

EasyGoogleMaps(
    apiKey: 'YOUR_API_KEY_HERE',
    address: 'Infinite Loop, Cupertino, CA 95014',
    title: 'Apple Campus',
)
  • When you change the address the map will automatically move the camera position to the new marker
  • Optionally give a width and height
  • API Key is Required from Google Maps

Screenshots #

1.0.0 #

  • Base Plugin

example/README.md

easy_google_maps_example #

Demonstrates how to use the easy_google_maps plugin.

Getting Started #

import 'package:easy_google_maps_example/api_key.dart';
import 'package:flutter/material.dart';
import 'package:easy_google_maps/easy_google_maps.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Easy Google Maps'),
        ),
        body: EasyGoogleMaps(
          apiKey: kGoogleMapsApiKey,
          address: 'Infinite Loop, Cupertino, CA 95014',
          title: 'Apple Campus',
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  easy_google_maps: ^1.0.0+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:easy_google_maps/easy_google_maps.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
easy_web_view ^1.0.1 1.0.1
flutter 0.0.0
geolocator ^5.1.5 5.3.0
google_maps_flutter ^0.5.21+12 0.5.24+1
Transitive dependencies
collection 1.14.11 1.14.12
cupertino_icons 0.1.3
equatable 1.1.0
flutter_plugin_android_lifecycle 1.0.6
google_api_availability 2.0.2
location_permissions 2.0.4+1
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
webview_flutter 0.3.19+8
Dev dependencies
flutter_test