easy_debounce_throttle 1.0.0+5 copy "easy_debounce_throttle: ^1.0.0+5" to clipboard
easy_debounce_throttle: ^1.0.0+5 copied to clipboard

An easy-to-use flutter package that provides debounce and throttle with Stream and WidgetBuilder.

4
likes
130/ 140
pub points
74%
popularity

We analyzed this package 17 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 35 API elements (34.3 %) have documentation comments.

Some symbols that are missing documentation: easy_debounce, easy_debounce.DebounceHandler.delay, easy_debounce.DebounceHandler.timer, easy_debounce.EasyDebounce.close, easy_debounce.EasyDebounce.debounce.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/debounce/easy_debounce.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/debounce/easy_debounce_builder.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

4
likes
130
pub points
74%
popularity

Publisher

unverified uploader

An easy-to-use flutter package that provides debounce and throttle with Stream and WidgetBuilder.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on easy_debounce_throttle