e621 1.0.0 copy "e621: ^1.0.0" to clipboard
e621: ^1.0.0 copied to clipboard

A client library for the API of imageboard using e621 fork of gelbooru.

0
likes
150/ 160
pub points
11%
popularity

We analyzed this package 14 hours ago, and awarded it 150 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

233 out of 236 API elements (98.7 %) have documentation comments.

Some symbols that are missing documentation: e621.Flag.Flag.fromMap, e621.Post.Post.fromMap, e621.Vote.Vote.fromMap.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:e621/e621.dart that imports:
  • package:e621/src/data_access_object.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
http ^1.2.0 1.2.1 1.2.1
http_parser ^4.0.2 4.0.2 4.0.2
meta ^1.12.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
150
pub points
11%
popularity

Publisher

verified publisherprojetretro.io

A client library for the API of imageboard using e621 fork of gelbooru.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

collection, http, http_parser, meta

More

Packages that depend on e621