dz_http 0.14.2-dev
dz_http: ^0.14.2-dev copied to clipboard

A composable, multi-platform, Future-based API for HTTP requests.

0
likes
110/ 130
pub points
32%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 107 out of 134 API elements (79.9 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

SDK issues found:

Package is not compatible with the Dart SDK.

Because it is not compatible with any of the supported runtimes: native-aot, native, js.

Package is not compatible with Dart SDK using runtime native-aot. Because:

  • package:dz_http/browser_client.dart that imports:
  • package:dz_http/src/browser_client.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime native. Because:

  • package:dz_http/browser_client.dart that imports:
  • package:dz_http/src/browser_client.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime js. Because:

  • package:dz_http/io_client.dart that imports:
  • package:dz_http/src/io_streamed_response.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http_parser^4.0.04.0.04.0.0
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
pedantic^1.10.01.11.11.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
110
pub points
32%
popularity

Publisher

dizoft.ru

A composable, multi-platform, Future-based API for HTTP requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

http_parser, meta, path, pedantic

More

Packages that depend on dz_http