dynamic_themes 0.1.0+1 icon indicating copy to clipboard operation
dynamic_themes: ^0.1.0+1 copied to clipboard

Allows you to specify a number of color themes for the user to choose from. Persits the selected theme across app restarts.

20
likes
90/ 130
pub points
89%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 15 API elements (73.3 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:dynamic_themes/dynamic_themes.dart that imports:
  • package:dynamic_themes/src/dynamic_theme.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dynamic_themes.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/dynamic_theme.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
shared_preferences^0.5.12+40.5.12+42.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.4
meta-1.7.01.7.0
path-1.8.11.8.1
path_provider_linux-0.0.1+22.1.5
path_provider_platform_interface-1.0.42.0.3
path_provider_windows-0.0.52.0.5
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.4
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.3
shared_preferences_windows-0.0.2+32.0.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1
win32-2.3.32.3.3
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.12+4` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.

20
likes
90
pub points
89%
popularity

Allows you to specify a number of color themes for the user to choose from. Persits the selected theme across app restarts.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, shared_preferences

More

Packages that depend on dynamic_themes