dungeon_world_data 2.0.5+9 icon indicating copy to clipboard operation
dungeon_world_data: ^2.0.5+9 copied to clipboard

Data dump of Dungeon World classes, moves, equipment, and more. Also mirrored as NPM package.

0
likes
110/ 140
pub points
6%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 126 out of 247 API elements (51.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.01.9.01.9.0
quiver^2.0.12.1.53.2.1
uuid^2.0.42.2.23.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.17.11.17.1
convert-2.1.13.1.1
crypto-2.1.53.0.2
matcher-0.12.140.12.14
path-1.8.31.8.3
stack_trace-1.11.01.11.0
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

The constraint `^2.0.4` on uuid does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.1.

0
likes
110
pub points
6%
popularity

Publisher

verified publisher icondungeonpaper.app

Data dump of Dungeon World classes, moves, equipment, and more. Also mirrored as NPM package.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

meta, quiver, uuid

More

Packages that depend on dungeon_world_data