dumble 0.8.9 copy "dumble: ^0.8.9" to clipboard
dumble: ^0.8.9 copied to clipboard

A Mumble transport client framework supporting multiple Mumble features such as fully encrypted udp transport or user management

4
likes
110/ 140
pub points
45%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

82 out of 354 API elements (23.2 %) have documentation comments.

Some symbols that are missing documentation: dumble.AudioClient.close, dumble.AudioClient.resetSequenceNumber, dumble.AudioClient.sequenceNumber, dumble.AudioCodec, dumble.AudioCodec.AudioCodec.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dumble/dumble.dart that imports:
  • package:dumble/src/listeners.dart that imports:
  • package:dumble/src/model/user_stats.dart that imports:
  • package:dumble/src/model/stats.dart that imports:
  • package:dumble/src/utils/utils.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 65 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/model/permission.dart:123:17

    ╷
123 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/model/permission.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/utils/var_int.dart:112:17

    ╷
112 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/var_int.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.0.0 3.1.1 3.1.1
fixnum ^1.0.0 1.1.0 1.1.0
meta ^1.3.0 1.15.0 1.15.0
pointycastle ^3.1.2 3.9.1 3.9.1
protobuf ^2.0.0 2.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
js - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

4
likes
110
pub points
45%
popularity

Publisher

verified publisherepnw.eu

A Mumble transport client framework supporting multiple Mumble features such as fully encrypted udp transport or user management

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

convert, fixnum, meta, pointycastle, protobuf

More

Packages that depend on dumble