duckma_client 0.0.4 copy "duckma_client: ^0.0.4" to clipboard
duckma_client: ^0.0.4 copied to clipboard

An interface with an adapter layer which tries to consume Dio with efficiency and smartly.

0
likes
120/ 160
pub points
25%
popularity

We analyzed this package 46 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/duckma/duckma_client was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: duckma_client,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

134 out of 151 API elements (88.7 %) have documentation comments.

Some symbols that are missing documentation: duckma_client, duckma_client.BaseInterceptor, duckma_client.BaseInterceptor.BaseInterceptor, duckma_client.ConnectivityExtension, duckma_client.ConnectivityExtension.resolve.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:duckma_client/duckma_client.dart that imports:
  • package:duckma_client/src/interceptors/connectivity_interceptor.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:duckma_client/duckma_client.dart that imports:
  • package:duckma_client/src/utils/connectivity_request_retrier.dart that imports:
  • package:duckma_client/src/extensions/connectivity_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:duckma_client/duckma_client.dart that imports:
  • package:duckma_client/src/utils/connectivity_request_retrier.dart that imports:
  • package:duckma_client/src/extensions/connectivity_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:duckma_client/duckma_client.dart that imports:
  • package:duckma_client/src/utils/connectivity_request_retrier.dart that imports:
  • package:duckma_client/src/extensions/connectivity_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:duckma_client/duckma_client.dart that imports:
  • package:duckma_client/src/utils/connectivity_request_retrier.dart that imports:
  • package:duckma_client/src/extensions/connectivity_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

WARNING: Missing case clause for 'badCertificate'.

lib/src/interceptors/base_interceptor.dart:18:5

   ╷
18 │     switch (err.type) {
   │     ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/interceptors/base_interceptor.dart

WARNING: Missing case clause for 'badResponse'.

lib/src/interceptors/base_interceptor.dart:18:5

   ╷
18 │     switch (err.type) {
   │     ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/interceptors/base_interceptor.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus ^5.0.2 5.0.2 6.0.3
dio ^5.3.3 5.4.3+1 5.4.3+1
meta ^1.9.1 1.12.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
connectivity_plus_platform_interface - 1.2.4 2.0.0
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
flutter - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.2` on connectivity_plus does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
120
pub points
25%
popularity

Publisher

verified publisherduckma.com

An interface with an adapter layer which tries to consume Dio with efficiency and smartly.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity_plus, dio, meta

More

Packages that depend on duckma_client