dt_compress_image_package 0.0.4
dt_compress_image_package: ^0.0.4 copied to clipboard

Flutter Android iOS Linux macOS Windows

A package to compress image (png or jpg).

1
likes
60 / 110
pub points
40 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 12 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:dt_compress_image_package/dt_compress_image_package.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dt_compress_image_package.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/png_compress_level.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
image^2.1.92.1.193.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
petitparser-3.1.04.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.9` on image does not support the stable version `3.0.1`, that was published 4 days ago.

When image is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

1
likes
60
pub points
40%
popularity

A package to compress image (png or jpg).

Homepage

Documentation

API reference

Uploader

guqung6@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, image

More

Packages that depend on dt_compress_image_package