drift 2.16.0 copy "drift: ^2.16.0" to clipboard
drift: ^2.16.0 copied to clipboard

Drift is a reactive library to store relational data in Dart and Flutter applications.

1399
likes
140/ 140
pub points
99%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1256 out of 1260 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: backends.DelegatedDatabase.impl, backends.DelegatedDatabase.isSequential, backends.DelegatedDatabase.logStatements, drift.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.5.0 2.11.0 2.11.0
collection ^1.15.0 1.18.0 1.18.0
convert ^3.0.0 3.1.1 3.1.1
js >=0.6.3 <0.8.0 0.6.7 0.7.1
meta ^1.3.0 1.12.0 1.12.0
path ^1.8.0 1.9.0 1.9.0
sqlite3 ^2.4.0 2.4.0 2.4.0
stack_trace ^1.11.1 1.11.1 1.11.1
stream_channel ^2.1.0 2.1.2 2.1.2
web ^0.5.0 0.5.0 0.5.0
Transitive dependencies
Package Constraint Compatible Latest
ffi - 2.1.2 2.1.2
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1399
likes
140
pub points
99%
popularity

Publisher

verified publishersimonbinder.eu

Drift is a reactive library to store relational data in Dart and Flutter applications.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, collection, convert, js, meta, path, sqlite3, stack_trace, stream_channel, web

More

Packages that depend on drift