drag_drop_angular 1.0.2

  • Readme
  • Changelog
  • Installing
  • 0

travis build

Drag Drop library for Dart Angular-driven apps #

Designed to utilize HTML5 Drag and Drop API, it supports all major and modern browsers.

Due to nature of the underlying API, it's possible to implement system-wide drag'n'drop interactions.

It also provides ability to manage scroll-on-drag process.

Based on drag_drop package GitHub, Pub

Usage #

While reference is on the way, you can start exploring Live Examples or just run

pub serve web

Changelog #

1.0.2 #

  • Live examples

1.0.1 #

  • Added missing index.html to run demo-app

1.0.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  drag_drop_angular: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:drag_drop_angular/drag_drop.dart';
import 'package:drag_drop_angular/movement.dart';
import 'package:drag_drop_angular/scroll.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.1 <2.0.0