user_environment_angular 1.0.0

  • Readme
  • Changelog
  • Installing
  • 0

travis build

User Environment #

This package allows to detect the platform and the browser version used to view a web page.

Differentiated browsers are: IE, Edge, Chrome, Safari, Gecko, Opera, Electron, Other along with Mac, Windows and Other platforms.

Usage #

import 'package:angular2/angular2.dart';
import 'package:user_environment_angular/user_environment.dart';

  selector: 'my-directive',
  providers: const [
class MyDirective {

  MyDirective(UserEnvironment env) {
  if (env.platform.type == UserPlatformType.Mac &&
    env.browser.type == BrowserType.Chrome &&
    env.browser.productVersion('AppleWebkit') == new BrowserVersion('1.2.3')) {
      // Do something

Changelog #

1.0.0 #

  • Published version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  user_environment_angular: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:user_environment_angular/user_environment_angular.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.1 <2.0.0