draft_view 0.8.34+1
draft_view: ^0.8.34+1 copied to clipboard

A draft js renderer written in Dart! You can easily render your draft js object in Flutter!

1
likes
70 / 130
pub points
47 %
popularity

We analyzed this package on Jun 19, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 300 API elements (19.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:draft_view/draft_view.dart that imports:
  • package:draft_view/draft_view/plugin/plugins/link_plugin.dart that imports:
  • package:draft_view/draft_view/block/blocks/link_block.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/draft_view/block/blocks/blockquote_block.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/draft_view/block/blocks/list_block.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
audioplayers^0.17.20.17.40.19.0
flutterflutter0.0.00.0.0
url_launcher^5.7.105.7.106.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.4.0
path-1.8.01.8.0
path_provider-1.6.282.0.2
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.3
url_launcher_web-0.1.5+32.0.1
url_launcher_windows-0.0.1+32.0.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
win32-2.2.12.2.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.2` on audioplayers does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

The constraint `^5.7.10` on url_launcher does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0-0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

1
likes
70
pub points
47%
popularity

Publisher

Unknown

A draft js renderer written in Dart! You can easily render your draft js object in Flutter!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers, flutter, url_launcher

More

Packages that depend on draft_view