dox_core 2.0.0 copy "dox_core: ^2.0.0" to clipboard
dox_core: ^2.0.0 copied to clipboard

A perfect solution for your web backend development with dart that offers a wide range of features to help you build powerful and scalable web applications.

9
likes
130/ 160
pub points
19%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

199 out of 561 API elements (35.5 %) have documentation comments.

Some symbols that are missing documentation: aes_encryptor, aes_encryptor.AESEncryptor, aes_encryptor.AESEncryptor.AESEncryptor, aes_encryptor.AESEncryptor.iv, app.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dox_core/dox_core.dart that imports:
  • package:dox_core/storage/storage.dart that imports:
  • package:dox_core/storage/local_storage_driver.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/cache/cache_driver_interface.dart:1:1

  ╷
1 │ /// coverage:ignore-file
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/cache/cache_driver_interface.dart

INFO: Dangling library doc comment.

lib/interfaces/app_config.dart:1:1

  ╷
1 │ /// coverage:ignore-file
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/interfaces/app_config.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bcrypt ^1.1.3 1.1.3 1.1.3
dox_annotation ^1.0.5 1.0.5 1.0.5
encrypt ^5.0.3 5.0.3 5.0.3
mime ^1.0.4 1.0.5 1.0.5
path ^1.8.3 1.9.0 1.9.0
sprintf ^7.0.0 7.0.0 7.0.0
string_scanner ^1.1.0 1.3.0 1.3.0
uuid ^3.0.6 3.0.7 4.4.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
clock - 1.1.1 1.1.1
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
pointycastle - 3.9.1 3.9.1
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.6` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

9
likes
130
pub points
19%
popularity

Publisher

verified publisherdartondox.dev

A perfect solution for your web backend development with dart that offers a wide range of features to help you build powerful and scalable web applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

bcrypt, dox_annotation, encrypt, mime, path, sprintf, string_scanner, uuid

More

Packages that depend on dox_core