dotup_flutter_logger 0.3.2 icon indicating copy to clipboard operation
dotup_flutter_logger: ^0.3.2 copied to clipboard

Flutter widgets to present dotup_dart_logger logs.

3
likes
80/ 120
pub points
33%
popularity

We analyzed this package 6 days ago, and awarded it 80 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 10icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:dotup_flutter_logger/dotup_flutter_logger.dart that imports:
  • package:dotup_flutter_logger/src/db/database/LoggerEntity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/Entity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/SQLite/SqLiteRepository.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:dotup_flutter_logger/dotup_flutter_logger.dart that imports:
  • package:dotup_flutter_logger/src/db/database/LoggerEntity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/Entity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/SQLite/SqLiteRepository.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:dotup_flutter_logger/dotup_flutter_logger.dart that imports:
  • package:dotup_flutter_logger/src/db/database/LoggerEntity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/Entity.dart that imports:
  • package:dotup_flutter_logger/src/db/database/SQLite/SqLiteRepository.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: Unused import: 'package:dotup_dart_logger/dotup_dart_logger.dart'.

lib/src/LoggerView.dart:1:8

  ╷
1 │ import 'package:dotup_dart_logger/dotup_dart_logger.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/LoggerView.dart

INFO: Unused import: 'LogLevelFilter.dart'.

lib/src/LoggerView.dart:6:8

  ╷
6 │ import 'LogLevelFilter.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/LoggerView.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotup_dart_logger^0.2.00.2.00.6.3
dotup_flutter_widgets^0.5.20.5.34.0.0
flutterflutter0.0.00.0.0
sqflite^2.0.0+32.0.2+12.0.2+1
sqflite_common^2.0.0+22.2.1+12.2.1+1
sqflite_common_ffi^2.0.0+12.1.12.1.1
uuid^3.0.43.0.63.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
crypto-3.0.23.0.2
dotup_dart_utils-0.1.13.0.0
ffi-1.2.11.2.1
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
provider-5.0.06.0.3
sky_engine-0.0.990.0.99
sqlite3-1.7.11.7.1
synchronized-3.0.0+23.0.0+2
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.0` on dotup_dart_logger does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions dotup_dart_logger to update the constraint.

The constraint `^0.5.2` on dotup_flutter_widgets does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions dotup_flutter_widgets to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.