dotup_flutter_logger 0.7.0
dotup_flutter_logger: ^0.7.0 copied to clipboard

Flutter widgets to present dotup_dart_logger logs.

3
likes
90/ 130
pub points
46%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 69 API elements (10.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:dotup_flutter_logger/dotup_flutter_logger.dart that imports:
  • package:dotup_flutter_logger/src/LoggerView.dart that imports:
  • package:dotup_flutter_logger/src/LoggerList.dart that imports:
  • package:dotup_flutter_widgets/dotup_flutter_widgets.dart that imports:
  • package:dotup_flutter_widgets/src/layout/layout.dart that imports:
  • package:dotup_flutter_widgets/src/layout/platform_value.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

lib/dotup_flutter_logger.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/LoggerListController.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotup_dart_logger^0.6.00.6.00.6.0
dotup_flutter_widgets^0.7.00.7.42.1.3
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
dotup_dart_utils-0.1.10.1.1
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
provider-6.0.16.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.0` on dotup_flutter_widgets does not support the stable version `1.0.0`, that was published 10 days ago.

When dotup_flutter_widgets is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dotup_flutter_widgets to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.