dotup_flutter_active_window 0.1.1
dotup_flutter_active_window: ^0.1.1 copied to clipboard

A flutter plugin to get active foreground window on MacOS, Windows and Linux.

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/dotupNET/dotup_flutter was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 92 API elements (4.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:dotup_flutter_active_window/dotup_flutter_active_window.dart that declares support for platforms: Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/src/active_window.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/active_window_error.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotup_dart_utils^1.0.01.0.03.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on dotup_dart_utils does not support the stable version `2.0.0`, that was published 6 days ago.

When dotup_dart_utils is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dotup_dart_utils to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
70
pub points
0%
popularity

Publisher

dotup.de

A flutter plugin to get active foreground window on MacOS, Windows and Linux.

Homepage
Repository (missing)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

dotup_dart_utils, flutter

More

Packages that depend on dotup_flutter_active_window