doc_widget_builder 0.4.0 copy "doc_widget_builder: ^0.4.0" to clipboard
doc_widget_builder: ^0.4.0 copied to clipboard

The code generator to generate the documentation for doc_widget package.

1
likes
80/ 140
pub points
45%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: doc_widget_builder, doc_widget_builder.docWidgetBuilder.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:doc_widget_builder/doc_widget_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Statements in an if should be enclosed in a block.

lib/src/library.dart:199:7

    ╷
199 │ ┌       return hasDocumentation
200 │ │           ? removeDocumentationComment(field.documentationComment)
201 │ └           : null;
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/library.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=4.4.0 <6.0.0 5.13.0 6.4.1
build >=2.3.1 <3.0.0 2.4.1 2.4.1
build_config >=1.1.0 <3.0.0 1.1.1 1.1.1
code_builder >=4.3.0 <6.0.0 4.10.0 4.10.0
dart_style >=2.2.4 <6.0.0 2.3.2 2.3.6
doc_widget_annotation ^0.2.8 0.2.8 0.2.8
flutter flutter 0.0.0 0.0.0
source_gen ^1.2.3 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.1 8.9.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.4.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.