dns_client 0.1.0+2
dns_client: ^0.1.0+2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Dart implementation of DNS-over-HTTPS.

0
likes
80 / 110
pub points
78 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/dns_client_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 58 API elements (5.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dns_client/dns_client.dart that imports:
  • package:dns_client/src/dns_over_https.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
freezed_annotationany0.12.00.12.0
http^0.12.10.12.20.13.0
json_annotation^3.0.03.1.14.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
http_parser-3.1.44.0.0
meta-1.2.41.3.0
path-1.7.01.8.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`, that was published 21 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.0` on json_annotation does not support the stable version `4.0.0`, that was published 15 days ago.

When json_annotation is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.