djalmautil 1.1.4
djalmautil: ^1.1.4

Flutter Android iOS

Package to help calling common methods in projects.

6
likes
60 / 110
pub points
47 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 34 API elements (5.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:djalmautil/djalmautil.dart that imports:
  • package:djalmautil/src/internet_connection.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/src/color_to_materialcolor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/column_builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio>=3.0.9 <4.0.03.0.103.0.10
get>=3.0.0 <10.0.03.17.13.17.1
intl>=0.16.1 <1.0.00.16.10.16.1
money2>=1.3.0 <2.0.01.4.31.4.3
search_cep>=1.0.4 <2.0.01.0.43.0.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
xml-4.5.14.5.1
xml2json-4.4.04.4.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=1.0.4 <2.0.0` on search_cep does not support the latest published version `3.0.0+2`

pubspec.yaml:13:15

   ╷
13 │   search_cep: ">=1.0.4 <2.0.0"
   │               ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
60
pub points
47%
popularity

Package to help calling common methods in projects.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

d.apps2468@gmail.com

License

MIT (LICENSE)

Dependencies

dio, flutter, get, intl, money2, search_cep

More

Packages that depend on djalmautil