dio_http2_adapter 2.5.2 copy "dio_http2_adapter: ^2.5.2" to clipboard
dio_http2_adapter: ^2.5.2 copied to clipboard

An adapter that combines HTTP/2 and dio. Supports reusing connections, header compression, etc.

35
likes
140/ 140
pub points
97%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/cfug/dio/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 25 API elements (64.0 %) have documentation comments.

Some symbols that are missing documentation: dio_http2_adapter, dio_http2_adapter.ClientSetting, dio_http2_adapter.ClientSetting.ClientSetting, dio_http2_adapter.ConnectionManager.close, dio_http2_adapter.ConnectionManager.removeConnection.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dio_http2_adapter/dio_http2_adapter.dart that imports:
  • package:dio_http2_adapter/src/http2_adapter.dart that imports:
  • package:http2/http2.dart that imports:
  • package:http2/transport.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.2.0 5.4.3+1 5.4.3+1
http2 ^2.1.0 2.3.0 2.3.0
meta ^1.9.1 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

35
likes
140
pub points
97%
popularity

Publisher

verified publisherflutter.cn

An adapter that combines HTTP/2 and dio. Supports reusing connections, header compression, etc.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#dio #http2 #native #network

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, http2, meta

More

Packages that depend on dio_http2_adapter