dint 0.1.0
dint: ^0.1.0 copied to clipboard

Dint application.

0
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 12 API elements (25.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
The current Dart SDK version is 2.13.3.

    Because no versions of datastore match >0.1.3 <0.2.0 and datastore 0.1.3 depends on test_io ^0.1.0, datastore ^0.1.3 requires test_io ^0.1.0.
(1) So, because every version of test_io depends on test ^1.8.0, datastore ^0.1.3 requires test ^1.8.0.

    Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0, test >=1.16.0-nullsafety <1.16.0-nullsafety.18 requires typed_data >=1.3.0-nullsafety <1.3.0.
    And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.19-nullsafety.7.
    And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.12.0 <1.13.0 depends on test_api 0.2.14, test >=1.3.0 <1.13.0-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.19-nullsafety.7 or boolean_selector ^1.0.0.
    And because test >=1.13.0 <1.14.5 depends on test_api 0.2.15 and test >=1.14.5 <1.15.0 depends on test_api 0.2.16, test >=1.3.0 <1.15.0-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.19-nullsafety.7 or boolean_selector ^1.0.0.
    And because test >=1.15.0 <1.15.3 depends on test_api 0.2.17 and test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=1.3.0 <1.15.5-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.19-nullsafety.7 or boolean_selector ^1.0.0.
    And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=1.3.0 <1.16.6 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or boolean_selector ^1.0.0.
    And because test >=1.16.6 <1.16.7 depends on test_core 0.3.17 and test >=1.16.7 <1.16.8 depends on test_core 0.3.18, test >=1.3.0 <1.16.8 requires test_core 0.3.17 or 0.3.18 or typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or boolean_selector ^1.0.0.
    And because datastore ^0.1.3 requires test ^1.8.0 (1), datastore ^0.1.3 requires test_core 0.3.17 or 0.3.18 or typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or boolean_selector ^1.0.0 or test ^1.16.8.
    And because test >=1.17.6 depends on test_api 0.4.1 and test >=1.17.0 <1.17.6 depends on test_api 0.4.0, datastore ^0.1.3 requires test_core 0.3.17 or 0.3.18 or typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or 0.4.0 or 0.4.1 or boolean_selector ^1.0.0 or test >=1.16.8 <1.17.0.
    And because test >=1.16.8 <1.17.0 depends on test_core 0.3.19 which depends on args ^2.0.0, datastore ^0.1.3 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or 0.4.0 or 0.4.1 or boolean_selector ^1.0.0 or args ^2.0.0.
    And because dent 0.1.0 depends on both args ^1.5.0 and datastore ^0.1.3, dent 0.1.0 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or 0.4.0 or 0.4.1 or boolean_selector ^1.0.0.
    And because every version of flutter_test from sdk depends on both boolean_selector 2.1.0 and typed_data 1.3.0, if flutter_test any from sdk and dent 0.1.0 then test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or 0.2.19-nullsafety.7 or 0.2.19 or 0.4.0 or 0.4.1.
    And because every version of flutter_test from sdk depends on test_api 0.3.0 and no versions of dent match >0.1.0 <0.2.0, flutter_test from sdk is incompatible with dent ^0.1.0.
    So, because dint depends on both dent ^0.1.0 and flutter_test any from sdk, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.