devtools 2.3.3
devtools: ^2.3.3 copied to clipboard

A suite of web-based performance tooling for Dart and Flutter.

25
likes
90 / 130
pub points
96 %
popularity

We analyzed this package on Jun 23, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
devtools_server2.3.32.3.32.3.3
devtools_shared2.3.32.3.32.3.3
http^0.13.00.13.30.13.3
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.1.12.1.1
async-2.7.02.7.0
browser_launcher-1.0.01.0.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.03.0.0
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
logging-1.0.11.0.1
meta-1.4.01.4.0
mime-1.0.01.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pool-1.5.01.5.0
shelf-1.1.41.1.4
shelf_proxy-1.0.01.0.0
shelf_static-1.0.01.0.0
source_span-1.8.11.8.1
sse-4.1.04.1.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
usage-4.0.24.0.2
vm_service-7.1.07.1.0
webkit_inspection_protocol-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

25
likes
90
pub points
96%
popularity

Publisher

flutter.dev

A suite of web-based performance tooling for Dart and Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

devtools_server, devtools_shared, http

More

Packages that depend on devtools