deploy 0.0.1 copy "deploy: ^0.0.1" to clipboard
deploy: ^0.0.1 copied to clipboard

Deploy your Dart/Flutter application easily.

2
likes
90/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/ArthurRmd/deploy was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: deploy,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 1 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: deploy.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: Unused import: 'dart:convert'.

lib/src/services/ssh_service.dart:1:8

  ╷
1 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/services/ssh_service.dart

WARNING: The value of the local variable 'result' isn't used.

lib/src/services/ssh_service.dart:48:9

   ╷
48 │     var result = await sshClient.run(
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/services/ssh_service.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.6 3.4.10 3.4.10
dartssh2 ^2.7.3 2.8.2 2.8.2
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.2 1.5.2
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
pinenacl - 0.5.1 0.5.1
pointycastle - 3.9.0 3.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

2
likes
90
pub points
0%
popularity

Publisher

verified publisherarthur-rmd.dev

Deploy your Dart/Flutter application easily.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, dartssh2, yaml

More

Packages that depend on deploy