dependency_visitor 1.0.0
dependency_visitor: ^1.0.0 copied to clipboard

Visits root package, transitive and immediate dependencies in order to search given files.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dependency_visitor

With Flutter:

 $ flutter pub add dependency_visitor

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  dependency_visitor: ^1.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dependency_visitor/dependency_visitor.dart';
1
likes
130
pub points
13%
popularity

Visits root package, transitive and immediate dependencies in order to search given files.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

effective_dart, equatable, path, pubspec_lock_reader, universal_io, yaml

More

Packages that depend on dependency_visitor